Forumsee logo
Forumsee » Mobility » Windows phone » Read message
RSS: Subscribe to RSS

Windows 7 USB driver access denied for digital camera

Forum: Microsoft Windows - www.geekzone.co.nz
So had a look around here for a solution, and of course tried the magic internet at large, and I can't fix the following:

A USB camera (Olympus FE270) can't be accessed in Windows7. The "automagical" driver install on plugging in the device reports that is installed the USB driver, but the device is not working properly with "access denied". Code 18 if I'm not mistaken or my memory is bad.

Now having exhausted my old, not-often-used Windows experience (I'm a Unix/Linux hack) I turn to anyone who can point me in the correct direction.

I note:

 - I suspect it may have something to do with MTP, but the camera has no option to change between MTP, PTP or mass storage device.

 - the device driver, while not working correctly, does show the correct camera model. So *something* is working...

 - The user being used is a full administrator. As far as I can tell anyway

 - I have removed the USB hubs from the device manager and reinstalled. This successfully reinstalled the drivers for all sorts of other connected USB devices, but had the same issue with the camera.

 - Against all hope I tried to "reset" all the windows system files to be owned by the admin group, using TAKEOWN from the command line. I realise that this probably has all sorts of other side effects, but I was desperate.

 - I tried all sorts of places to download a specific FE270 driver from the Internet, but to no avail. I baulk at using one of the many "driver repair" applications that want to install what I suspect is malware/spyware. The Olympus site itself is next to useless.

This is not my PC that I use, It's my un-tech neighbour's PC. Apparently it's never worked for cameras and it annoys me to not find a solution. I'm familiar with looking under the hood in Linux, but am becoming increasing at sea with the latest windows version. Come Win8 I'll have the excuse of complete ignorance, and will never have to support family or friends ever again.... (I suspect it'll completely different, but still frustrating non-deterministic for users!)

Any tips of help appreciated. Is there something deep within the registry that'll help? Are their buried access policies somewhere? The issue seems similar to lots of things/pages/issues/fixes I find on the 'net, but nothing totally similar to this or anything that works.

Regards Scott
Date: Nov 10, 2012   



Last videos:

Samsung publishes three new videos to YouTube, showcasing the Gear 360
Samsung publishes three new videos to YouTube, showcasing the Gear 360
You can bypass Factory Reset Protection on the May security update with the Nexus 6P
You can bypass Factory Reset Protection on the May security update with the Nexus 6P
Windows 7, 8, 8.1, 10 Speed up/ramfree utillity
Windows 7, 8, 8.1, 10 Speed up/ramfree utillity

Tags

Cars ·
Travel ·
Pets ·
production-frontend