Forumsee logo
Forumsee » Mobility » Tablets » Read message
RSS: Subscribe to RSS

Samsung - Galaxy Tab 2 10.1 Wifi - Can't Connect to Dlink DIR-645 Router.

Galaxy Tab 2 General - xda-developers - forum.xda-developers.com
Galaxy Tab 2 10.1 Wifi - Can't Connect to Dlink DIR-645 Router.

I'm having major troubles with my girlfriends Galaxy Tab 2 10.1 Wifi connection.

At my house it connects perfectly.

At her house, with the Dlink DIR-645 N router it tries to connect. Tries to obtain an IP Address for a while, then says that it can't connect because the signal is too weak. (which it isn't) Full bars.

Many other devices connect to this Wifi flawlessly. (iPhone, Galaxy S III, Galaxy Nexus, Galaxy Tab 10.1, ASUS EEE-PC)

I've tried changing channels in the router settings,

I've tried taking off the security (WPA2)

I've tried renaming the SSID

I've tried adding the connection manually on the tablet. (not connect via scan)

I've tried updating the firmware on the Router and the Tablet.

I've tried a wipe/factory reset on the Tablet.

The only way I can get it to connect is to have it connect with a Static IP Address. If i do this, it'll connect and have internet access for a while. But sooner or later it gets booted. I don't want to set up static Ip address on the her router.

And I'm just confused that this doesn't work. Any suggestions? Should i try a custom rom and hope that it's a software issue?

It's going to be hard to get Samsung service to replace it, because it seems to work fine on some other routers.
Date: Sep 19, 2012    Labels: Samsung



Last videos:

Is my tablet fixable?
Is my tablet fixable?
Nextbook Ares 8 No Home Screen
Nextbook Ares 8 No Home Screen

Tags

Cars ·
Travel ·
Pets ·
production-frontend