Forumsee logo
Forumsee » Mobility » Tablets » Read message
RSS: Subscribe to RSS

Two Rooted & Flashed Kindle Fire (gen1) Issues

Kindle Fire Q&A - xda-developers - forum.xda-developers.com
Hello all,

I have checked and used this forum GREATLY while trying to root my Kindle Fire (1st Generation) and flash the newest Jelly Bean ROM, so first off, thank you to all who contributed to other threads. I'm having two annoying issues that is keeping me from really loving the upgraded functionality of my kindle. The issues are:

1. Ever since the flash of the new Jelly Bean ROM, my computer won't recognize my kindle unless it's mounted via TWRP.

2. I cannot move a certain .ISO file from my SD Card to my system folder

First things first, issue #1. After I flashed the newest Jelly Bean ROM last week, my computer (well any computer really) fails to recognize my kindle. I tried re-downloading the ADB Google drivers from the SDK app, but that didn't work. In my device manager, I can't even find any reference to the Google USB drivers at all, so I can't uninstall then re-install them. And even after I install them again from the SDK program, they still don't show up. Additionally, the only time my computer recognizes my kindle is when I boot it in Recovery Mode. If the SD Card is not mounted within TWRP, my computer will find a "Removable Drive" (which I can't access), but if the SD Card is Mounted within TWRP, it finds the Kindle Fire and allows me to access the files on only the SD Card. I even turned on and off USB debug mode on the kindle to see if that did anything. No luck.

Now, issue #2. All of this is pretty much just being done for games. I have two .ISO files of different games that I burned from games I own. One file is on the SD Card and there is not enough room for the other ISO game file. Naturally, I thought I'd move one of the games to the system folder (or any folder not within the SD Card) so I can have access to both games on the same kindle. I thought about using ADB to manually push/pull the file, but that doesn't work unless my computer recognizes my device. I also tried downloading Root Manager, but my kindle crashes whenever I try to move the large file off the SD card. I did test and was able to move a small picture file from the SD Card to the System folder, so I know it can work when I give myself root and RW permissions. Is there a size limit to what can be moved via a Root File Manager? I have tried 3 different programs that all crashed when trying to move or copy the file. I did also notice that the game file has a small badge on it's icon. Not sure if that means anything or if that's just saying the file is copy protected.

Oh, and the KFU will only recognize the device when it's in Recovery Mode. That's the only time the Kindle will obey commands from KFU 9.6.

Ideally, I'd like to not have to re-flash or re-root my kindle if at all necessary. I'm hoping it's a simple fix. Any help would be greatly appreciated!
Date: Feb 5, 2013   



Last videos:

Acer Aspire Switch Alpha 12 - SP4 competitor
Acer Aspire Switch Alpha 12 - SP4 competitor
Get Data off Samsung Galaxy...
Get Data off Samsung Galaxy...

Tags

Cars ·
Travel ·
production-frontend