Forumsee logo
Forumsee » Mobility » Cellphones » Read message
RSS: Subscribe to RSS

Android Device not recognized / MTP ADB driver problem

Droid Incredible 2 General - xda-developers - forum.xda-developers.com
I'm about at my wit's end with this. Just for information sake I'm running Cyanogenmod10 on an Incredible 2.

Recently, about a week ago, I "removed" Windows Media Player from my Windows 7 services menu (because it's a piece of **** and I use MPC-HC), and didn't notice anything wrong until I tried to sync my Incredible 2 with Mediamonkey again to update my music collection and found that it wouldn't recognized the Android device.

After ****ing around with my drivers in device manager for a bit and doing some Google searches to try and figure out what the problem was, I came across the idea that it might be something with WMP and how it has MTP drivers installed that Mediamonkey needs to see the Android device in its program. This was confirmed on the MM wiki. So I re-allowed WMP via Windows service features and it still wouldn't recognize the device.

I've tried everything short of a fresh install and nothing works. Tried updating the ADB drivers, that didn't work. Tried deleting them and installing them manually, that didn't work. Tried downloading and installing the next version of WMP to see if that would refresh whatever drivers I needed, and get told that the "update doesn't apply to my computer". Tried installing the Android SDK toolkit to see if I could manually install the drivers without using device manager and that didn't seem to work either. Even tried installing the ****ty proprietary HTC Sync bloatware from HTC's website to see if that would give me the drivers I needed.

Then I tried backing up my phone data, doing a clean wipe of my phone through recovery, and putting stock Android on my phone to see if I could install the necessary MTP notification drivers from my phone onto my computer that way after I idiotically deleted them from device manager. The installer tells me it fails every time I try to connect the Incredible to my computer via USB. Currently I restored my CM10 installation and can't figure out what to do.

Now I have a royal cluster**** of things that may or may not work and I still can't get MM or WMP to recognize the device.
Date: Nov 20, 2012   


Last videos:

Bypass FRP Samsung Galaxy J3 Pro 2017
Bypass FRP Samsung Galaxy J3 Pro 2017
Proper way to change back cover in Samsung Galaxy A5
Proper way to change back cover in Samsung Galaxy A5
Unlock user google account problem - how to remove delete it - simple steps
Unlock user google account problem - how to remove delete it - simple steps
LG G5 hardware solution part by part disassembly tutorial - video
LG G5 hardware solution part by part disassembly tutorial - video
Microphone repair in Samsung Galaxy S7 G930F with simple tools - video tutorial
Microphone repair in Samsung Galaxy S7 G930F with simple tools - video tutorial
Samsung Galaxy S5 not working sensors - gyroscope and accelerometer problem
Samsung Galaxy S5 not working sensors - gyroscope and accelerometer problem
Help with Sony Xperia Z1 Compact D5503 hardware repair
Help with Sony Xperia Z1 Compact D5503 hardware repair
Not turning on Sony Xperia Z3 Compact - video solution 100% working
Not turning on Sony Xperia Z3 Compact - video solution 100% working

Tags

Cars ·
Travel ·
Pets ·
production-frontend