Forumsee logo
Forumsee » Mobility » Cellphones » Read message
RSS: Subscribe to RSS

Samsung - Android 'Debug enabled device' is not showing up on Eclipse

Galaxy S II Q&A - xda-developers - forum.xda-developers.com
Android 'Debug enabled device' is not showing up on Eclipse

Hello!

I have gone through a lot of threads before posting this here. I am facing an issue with Android device debugging - the device isn't getting listed on Devices tab in Eclipse IDE. (Please refer to screenshots) (To get 'Devices' tab 'Windows -> Show view -> Devices'). So while starting to debug there is no way to choose a device as device listing shows blank. The strange thing is that it used to work fine before and under windows explorer I can browse the files.

I am using Windows Vista Home premium, 32-bit OS

What all I have tried:

In phone:

1. USB debugging is enabled in phone under 'Settings-> Developer options'

2. Disabled and enabled USB debugging

3. Restarted the phone

In Eclipse:

1. Under 'Debug configurations->Target(tab)', 'Always prompt to pick device' is selected. It prompts but doesn't show any device on the device list!

2. Tried resting ADB under Devices tab. (To get 'Devices' tab 'Windows -> Show view -> Devices'

3. Reinstalled latest Android SDK along with ADB

4. Installed Eclipse Juno

In windows CMD under /platform-tools/ directory where the Android SDK Tools is installed, ran the following commands without getting any positive outcome:

Shut down Eclipse, unplugged the device and tried running:

adb kill-server

adb start-server

Plugged it back in and ran

adb devices

Mobile device details:

Model = Galaxy S2 GT-i9100

Rooted = yes

OS Ver. = 4.0.3

Kernel ver. = 3.0.15

hardcore@speedmod-s2-ics #k3-27b

Other details can be found in the attached screenshot.

Eclipse version: Indigo Service Release 1

Build id: 20110916-0149

Any help will be appreciated,

Thanks,

Ambar!
Date: Oct 8, 2012    Labels: Samsung


Last videos:

How to Put MP3/M4A/FLAC/AIFF Music to Huawei P9 ?
How to Put MP3/M4A/FLAC/AIFF Music to Huawei P9 ?
Samsung j1 mini lcd screen replacement
Samsung j1 mini lcd screen replacement
Sony Xperia Z not Charging 100% tested
Sony Xperia Z not Charging 100% tested
professional smartphone Repair deep Level 4 Full videos
professional smartphone Repair deep Level 4 Full videos
professional smartphone Repair deep Level 4 Full videos
professional smartphone Repair deep Level 4 Full videos
professional smartphone Repair deep Level 4 Full videos
professional smartphone Repair deep Level 4 Full videos
professional smartphone Repair deep Level 4 Full videos
professional smartphone Repair deep Level 4 Full videos
professional smartphone Repair deep Level 4 Full videos
professional smartphone Repair deep Level 4 Full videos

Tags

Cars ·
Travel ·
Pets ·
production-frontend